summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild')
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild b/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild
index 95eeb877e49d..a8b42d05638f 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild,v 1.11 2007/01/06 18:26:36 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.4.3-r3.ebuild,v 1.12 2007/04/03 20:51:40 seemant Exp $
inherit eutils flag-o-matic versionator autotools
@@ -14,7 +14,7 @@ SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="krb4 tcl ipv6 doc"
+IUSE="krb4 tcl ipv6 doc berkdb"
RDEPEND="!virtual/krb5
sys-libs/com_err
@@ -24,6 +24,15 @@ DEPEND="${RDEPEND}
doc? ( virtual/tetex )"
PROVIDE="virtual/krb5"
+pkg_setup() {
+ if use berkdb ; then
+ eerror "Please export your current kerberos db because"
+ eerror "we are now using the built-in db with its new locations"
+ eerror "Once you have exported your db, please set the -berkdb"
+ eerror "USE flag for this package"
+ fi
+}
+
src_unpack() {
unpack ${MY_P}-signed.tar
unpack ./${MY_P}.tar.gz
@@ -99,14 +108,4 @@ src_install() {
pkg_postinst() {
elog "See /usr/share/doc/${PF}/html/krb5-admin/index.html for documentation."
- echo ""
- echo ""
- ewarn "PLEASE READ THIS"
- ewarn "This release of mit-krb5 now depends on an external version"
- ewarn "of the com_err library. Please make sure to run revdep-rebuild"
- ewarn "to ensure the integrity of the linking on your system"
- echo ""
- epause 10
- ebeep
-
}