summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-core/lc-core-0.5.95.ebuild')
-rw-r--r--app-leechcraft/lc-core/lc-core-0.5.95.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-leechcraft/lc-core/lc-core-0.5.95.ebuild b/app-leechcraft/lc-core/lc-core-0.5.95.ebuild
deleted file mode 100644
index fd715d42a301..000000000000
--- a/app-leechcraft/lc-core/lc-core-0.5.95.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-0.5.95.ebuild,v 1.1 2013/05/02 15:27:27 pinkbyte Exp $
-
-EAPI="5"
-
-EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
-EGIT_PROJECT="leechcraft-${PV}"
-
-inherit eutils confutils leechcraft
-
-DESCRIPTION="Core of LeechCraft, the modular network client"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc +sqlite postgres"
-
-COMMON_DEPEND=">=dev-libs/boost-1.46
- dev-qt/qtcore:4
- dev-qt/qtdeclarative:4
- dev-qt/qtgui:4
- dev-qt/qtscript:4
- dev-qt/qtsql:4[postgres?,sqlite?]"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${COMMON_DEPEND}
- dev-qt/qtsvg:4
- || (
- kde-base/oxygen-icons
- x11-themes/kfaenza
- )"
-
-REQUIRED_USE="|| ( postgres sqlite )"
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_PLUGINS=False
- $(cmake-utils_use_with doc DOCS)
- )
- if [[ ${PV} != 9999 ]]; then
- mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dohtml -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
-}