summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild')
-rw-r--r--app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
new file mode 100644
index 000000000000..616ababffc9a
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild,v 1.1 2014/11/11 23:28:53 tamiko Exp $
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="http://grabcartoons.sourceforge.net/ https://github.com/zzamboni/grabcartoons"
+
+EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+
+if [[ "${PV}" != "9999" ]] ; then
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT="cb230f01fb288a0b9f0fc437545b97d06c846bd3"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.8.4-fix-install-paths.patch
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+ dodoc ChangeLog README
+}