summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/smstools/smstools-2.2.1.ebuild')
-rw-r--r--app-mobilephone/smstools/smstools-2.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-mobilephone/smstools/smstools-2.2.1.ebuild b/app-mobilephone/smstools/smstools-2.2.1.ebuild
new file mode 100644
index 000000000000..d83e90c0d4c7
--- /dev/null
+++ b/app-mobilephone/smstools/smstools-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smstools/smstools-2.2.1.ebuild,v 1.1 2006/06/14 13:55:57 chainsaw Exp $
+
+DESCRIPTION="Send and receive short messages through GSM modems"
+HOMEPAGE="http://smstools.meinemullemaus.de/"
+SRC_URI="http://www.meinemullemaus.de/software/${PN}/packages/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/smsd
+ dobin scripts/sendsms scripts/sms2html
+ dobin scripts/sms2unicode scripts/unicode2sms
+ insinto /etc
+ newins examples/smsd.conf.easy smsd.conf
+ newinitd ${FILESDIR}/smsd.initd smsd
+}