summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/akonadi-server/akonadi-server-1.1.2.ebuild')
-rw-r--r--app-office/akonadi-server/akonadi-server-1.1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-office/akonadi-server/akonadi-server-1.1.2.ebuild b/app-office/akonadi-server/akonadi-server-1.1.2.ebuild
new file mode 100644
index 000000000000..c6ed2e1511c2
--- /dev/null
+++ b/app-office/akonadi-server/akonadi-server-1.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/akonadi-server/akonadi-server-1.1.2.ebuild,v 1.1 2009/04/30 20:30:21 patrick Exp $
+
+EAPI="2"
+
+inherit qt4 cmake-utils
+
+DESCRIPTION="The server part of Akonadi"
+HOMEPAGE="http://pim.kde.org/akonadi"
+SRC_URI="http://download.akonadi-project.org/${P/-server/}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+mysql"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-sql:4[mysql?]
+ x11-libs/qt-test:4
+ x11-misc/shared-mime-info"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6.0
+ dev-libs/boost
+ dev-libs/libxslt
+ >=kde-base/automoc-0.9.88"
+
+S="${WORKDIR}/${P/-server/}"
+
+src_prepare() {
+ # Don't check for mysql, avoid an automagic dep.
+ if ! use mysql; then
+ sed -e '/mysqld/s/find_program/#DONOTWANT &/' \
+ -i "${S}"/server/CMakeLists.txt || die 'Sed failed.'
+ fi
+}