summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild')
-rw-r--r--app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild b/app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild
new file mode 100644
index 000000000000..2aaab60cc445
--- /dev/null
+++ b/app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-librapi2/synce-librapi2-0.13.1.ebuild,v 1.1 2009/01/21 11:27:43 mescalinum Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="SynCE - RAPI communication library"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ >=dev-python/pyrex-0.9.6
+ >=dev-libs/check-0.8.2
+ =app-pda/synce-libsynce-${synce_PV}*"
+RDEPEND="${DEPEND}"
+
+SRC_URI="mirror://sourceforge/synce/librapi2-${PV}.tar.gz"
+S="${WORKDIR}/librapi2-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc BUGS README README.contributing README.design TODO ChangeLog
+}