summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/syncevolution/ChangeLog10
-rw-r--r--app-pda/syncevolution/Manifest14
-rw-r--r--app-pda/syncevolution/metadata.xml8
-rw-r--r--app-pda/syncevolution/syncevolution-1.0.ebuild60
4 files changed, 92 insertions, 0 deletions
diff --git a/app-pda/syncevolution/ChangeLog b/app-pda/syncevolution/ChangeLog
new file mode 100644
index 000000000000..5da7722fcac9
--- /dev/null
+++ b/app-pda/syncevolution/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pda/syncevolution
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/ChangeLog,v 1.1 2010/06/26 03:19:47 tester Exp $
+
+*syncevolution-1.0 (26 Jun 2010)
+
+ 26 Jun 2010; Olivier CrĂȘte <tester@gentoo.org> +syncevolution-1.0.ebuild,
+ +metadata.xml:
+ Initial import, fixes bug #225221
+
diff --git a/app-pda/syncevolution/Manifest b/app-pda/syncevolution/Manifest
new file mode 100644
index 000000000000..64fb09849f3a
--- /dev/null
+++ b/app-pda/syncevolution/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST syncevolution-1.0.tar.gz 11486957 RMD160 e7af91e17b426a8f26f8af18203c6b12d87e7696 SHA1 12d7ed0a94646d09ca930951e5a8034d8cb8142a SHA256 d5964eaffcbe70e0cc8c166ec557a887bb2df668117d67a7336eeb36d6df3312
+EBUILD syncevolution-1.0.ebuild 1549 RMD160 b3a5236497b45d9e05d3255a2bb739ac8e17b7be SHA1 b16fc71ee024c51f036c343aec9b964d7085ed6d SHA256 fb3a10fecddaa4a8953fe294311612e76baae77ac9013efe7b09152ccf0d5057
+MISC ChangeLog 380 RMD160 5d386bb773651aab963e772d56104e394559f04b SHA1 41281c616365e5f8f878c587358e1ea1f16696bb SHA256 ffcf32bf0e04a2cad45a9ffcd214955311d4acd206d329829519b73d74d640fc
+MISC metadata.xml 218 RMD160 dcf0864821f82cd4da3e0da4d518166f6045b7b5 SHA1 ca615ae28fbffc0e7e3d1e51e189fbd245fddcc4 SHA256 983941334731e33b40df7a8643ee1f0e415ff4a4e2c90e1a4ac80a852792fb47
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwlcdgACgkQmOfEJZHYOKfz+gCg4LVQq8VVMc+c8Be4BsxuL+BC
+0T4An3FoNqez3lI6Ro/NgYoXIOLabcs9
+=bWFX
+-----END PGP SIGNATURE-----
diff --git a/app-pda/syncevolution/metadata.xml b/app-pda/syncevolution/metadata.xml
new file mode 100644
index 000000000000..0945d734a594
--- /dev/null
+++ b/app-pda/syncevolution/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+<maintainer>
+ <email>tester@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-pda/syncevolution/syncevolution-1.0.ebuild b/app-pda/syncevolution/syncevolution-1.0.ebuild
new file mode 100644
index 000000000000..54f4eee5f52e
--- /dev/null
+++ b/app-pda/syncevolution/syncevolution-1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/syncevolution/syncevolution-1.0.ebuild,v 1.1 2010/06/26 03:19:47 tester Exp $
+
+EAPI=2
+
+inherit gnome2
+
+DESCRIPTION="A SyncML desktop client and server"
+HOMEPAGE="http://syncevolution.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sqlite +gtk +eds bluetooth +gnome"
+
+SRC_URI="http://downloads.syncevolution.org/syncevolution/sources/${P}.tar.gz"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.16
+ >=net-libs/libsoup-2.4
+ >=sys-apps/dbus-1.2
+ x11-libs/libnotify
+ >=gnome-base/gnome-keyring-2.20
+ gtk? ( >=x11-libs/gtk+-2.18:2
+ dev-libs/libunique )
+ eds? ( >=gnome-extra/evolution-data-server-1.2
+ >=dev-libs/libical-0.43 )
+ bluetooth? (
+ >=net-wireless/bluez-4
+ >=dev-libs/openobex-1.5
+ gnome? ( >=net-wireless/gnome-bluetooth-2.28 ) )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-python/docutils
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.37.1"
+
+DOCS="README NEWS AUTHORS HACKING"
+
+pkg_setup() {
+ G2CONF="--with-rst2man=/usr/bin/rst2man.py
+ --with-rst2html=/usr/bin/rst2html.py
+ --enable-dbus-service
+ $(use_enable bluetooth)
+ $(use_enable sqlite)
+ $(use_enable eds ebook)
+ $(use_enable eds ecal)"
+ if use bluetooth; then
+ G2CONF="${G2CONF}
+ $(use_enable gnome gnome-bluetooth-panel-plugin)"
+ else
+ G2CONF="${G2CONF} --disable-gnome-bluetooth-panel-plugin"
+ fi
+ if use gtk; then
+ G2CONF="${G2CONF} --enable-gui=gtk"
+ else
+ G2CONF="${G2CONF} --enable-gui=no"
+ fi
+}