summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild')
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..3e4779e60e07
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild,v 1.1 2005/05/06 16:26:30 latexer Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-configurable.diff.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+IUSE="doc"
+
+RDEPEND=">=sys-apps/sed-4.0
+ >=dev-lang/mono-1.1.2
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/orbit-2.8.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~x86 ~ppc ~ppc"
+
+src_unpack() {
+ unpack ${A}
+
+ # disable building of samples (#16015)
+ cd ${S}
+ epatch ${WORKDIR}/${P}-configurable.diff
+ export WANT_AUTOMAKE="1.8"
+ aclocal || die
+ automake || die
+ autoconf || die
+ libtoolize --copy --force
+
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+
+ local myconf=""
+ # These are the same as from gtk-sharp-component.eclass
+ for package in art gda glade gnome gnomedb gnomevfs gtkhtml rsvg vte
+ do
+ myconf="${myconf} --disable-${package}"
+ done
+
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ emake assemble || die "Failed to generate docs"
+ fi
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/lib /gacdir /usr/lib /package ${PN}-2.0" \
+ DESTDIR=${D} install || die
+
+ dodoc README* ChangeLog
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ insinto $(monodoc --get-sourcesdir)
+ doins gtk-sharp-docs.{tree,zip}
+ fi
+}
+
+pkg_postinst() {
+ if use doc && ! has_version dev-util/monodoc
+ then
+ ewarn
+ ewarn "Although 'doc' is in the USE flag list, gtk-sharp will"
+ ewarn "not install its monodoc documentation unless you have monodoc"
+ ewarn "installed. If you want the documentation to be available in"
+ ewarn "monodoc, please emerge monodoc then re-emerge gtk-sharp."
+ ewarn
+ fi
+}