summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild')
-rw-r--r--dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild b/dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild
new file mode 100644
index 000000000000..0c5484e17924
--- /dev/null
+++ b/dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsopenssl/hsopenssl-0.10.3.5.ebuild,v 1.1 2013/11/14 09:12:16 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HsOpenSSL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Partial OpenSSL binding for Haskell"
+HOMEPAGE="https://github.com/phonohawk/HsOpenSSL"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fast-bignum"
+
+RDEPEND=">=dev-haskell/network-2.1.0.0:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ dev-libs/openssl
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag fast-bignum fast-bignum)
+}