summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.6.1-r12.ebuild')
-rw-r--r--dev-lang/perl/perl-5.6.1-r12.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-lang/perl/perl-5.6.1-r12.ebuild b/dev-lang/perl/perl-5.6.1-r12.ebuild
index 93b337a68e4e..50fdb223d3e8 100644
--- a/dev-lang/perl/perl-5.6.1-r12.ebuild
+++ b/dev-lang/perl/perl-5.6.1-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.6.1-r12.ebuild,v 1.6 2003/08/22 13:01:06 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.6.1-r12.ebuild,v 1.7 2003/09/06 22:27:51 msterret Exp $
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
MM_VERSION="6.05"
@@ -22,7 +22,7 @@ DEPEND="sys-apps/groff
>=sys-apps/portage-2.0.45-r5
>=sys-apps/sed-4
${RDEPEND}"
-
+
src_unpack() {
unpack ${A}
@@ -52,7 +52,7 @@ src_compile() {
if [ "${ARCH}" = "alpha" ]; then
CFLAGS="${CFLAGS} -fPIC"
CXXFLAGS="${CXXFLAGS} -fPIC"
- fi
+ fi
local myconf
if [ "`use gdbm`" ]
@@ -74,7 +74,7 @@ src_compile() {
fi
# put in built-in removal patch
- patch -p1 < ${FILESDIR}/${PV}-builtin-fixup.diff || die
+ patch -p1 < ${FILESDIR}/${PV}-builtin-fixup.diff || die
patch -p0 < ${FILESDIR}/${PV}-op-test-fix.diff || die
# configure for libperl.so
@@ -118,9 +118,9 @@ src_compile() {
cd ${S}
# put in built-in removal patch
- patch -p1 < ${FILESDIR}/${PV}-builtin-fixup.diff || die
+ patch -p1 < ${FILESDIR}/${PV}-builtin-fixup.diff || die
patch -p0 < ${FILESDIR}/${PV}-op-test-fix.diff || die
-
+
# configure for libperl.a
# this is gross -- from Christian Gafton, Red Hat
cat > config.over <<EOF
@@ -174,7 +174,7 @@ EOF
mv Makefile Makefile_orig
sed -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
Makefile_orig > Makefile
-
+
make || die
# Parallel make fails
@@ -182,20 +182,20 @@ EOF
if [ `expr "$PARCH" ":" "sparc"` -gt 4 ]; then
echo "Skipping tests on this platform"
else
- make test
+ make test
fi
}
src_install() {
-#The following is to handle international users. Perl does nls post-install
- export LC_ALL=C
+#The following is to handle international users. Perl does nls post-install
+ export LC_ALL=C
export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
insinto /usr/lib/perl5/${PV}/${PARCH}/CORE/
doins ${WORKDIR}/libperl.so
dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
-
+
# make -f Makefile \
# INSTALLMAN1DIR=${D}/usr/share/man/man1 \
@@ -228,7 +228,7 @@ src_install() {
dodoc Changes* Artistic Copying README Todo* AUTHORS
prepalldocs
-
+
# HTML Documentation
dodir /usr/share/doc/${PF}/html
${D}/usr/bin/perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html