summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mpfr/files/2.3.0/patch01')
-rw-r--r--dev-libs/mpfr/files/2.3.0/patch0183
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/mpfr/files/2.3.0/patch01 b/dev-libs/mpfr/files/2.3.0/patch01
new file mode 100644
index 000000000000..f31505aed7c6
--- /dev/null
+++ b/dev-libs/mpfr/files/2.3.0/patch01
@@ -0,0 +1,83 @@
+diff -Naurd mpfr-2.3.0-a/Makefile.am mpfr-2.3.0-b/Makefile.am
+--- mpfr-2.3.0-a/Makefile.am 2007-08-29 10:18:11.000000000 +0000
++++ mpfr-2.3.0-b/Makefile.am 2007-09-02 23:19:32.000000000 +0000
+@@ -32,8 +32,13 @@
+
+ MAKEINFOFLAGS = --enable-encoding
+
+-get_patches.c: PATCHES get_patches.sh
+- ./get_patches.sh > $@ || rm -f $@
++# Important note: If for some reason, srcdir is read-only at build time
++# (and you use objdir != srcdir), then you need to rebuild get_patches.c
++# (with "make get_patches.c") just after patching the MPFR source. This
++# should not be a problem in practice, in particular because "make dist"
++# automatically rebuilds get_patches.c before generating the archives.
++$(srcdir)/get_patches.c: PATCHES get_patches.sh
++ (cd $(srcdir) && ./get_patches.sh) > $@ || rm -f $@
+
+ # Do not add get_patches.c to CLEANFILES so that this file doesn't
+ # need to be (re)built as long as no patches are applied. Anyway the
+diff -Naurd mpfr-2.3.0-a/Makefile.in mpfr-2.3.0-b/Makefile.in
+--- mpfr-2.3.0-a/Makefile.in 2007-08-29 10:27:18.000000000 +0000
++++ mpfr-2.3.0-b/Makefile.in 2007-09-02 23:59:30.000000000 +0000
+@@ -1665,8 +1665,13 @@
+ uninstall-info-am uninstall-libLTLIBRARIES
+
+
+-get_patches.c: PATCHES get_patches.sh
+- ./get_patches.sh > $@ || rm -f $@
++# Important note: If for some reason, srcdir is read-only at build time
++# (and you use objdir != srcdir), then you need to rebuild get_patches.c
++# (with "make get_patches.c") just after patching the MPFR source. This
++# should not be a problem in practice, in particular because "make dist"
++# automatically rebuilds get_patches.c before generating the archives.
++$(srcdir)/get_patches.c: PATCHES get_patches.sh
++ (cd $(srcdir) && ./get_patches.sh) > $@ || rm -f $@
+
+ tune:
+ $(MAKE) $(AM_MAKEFLAGS) tuneup$(EXEEXT)
+diff -Naurd mpfr-2.3.0-a/PATCHES mpfr-2.3.0-b/PATCHES
+--- mpfr-2.3.0-a/PATCHES 2007-08-29 10:18:11.000000000 +0000
++++ mpfr-2.3.0-b/PATCHES 2007-09-02 23:59:50.000000000 +0000
+@@ -0,0 +1 @@
++get_patches
+diff -Naurd mpfr-2.3.0-a/VERSION mpfr-2.3.0-b/VERSION
+--- mpfr-2.3.0-a/VERSION 2007-08-29 10:18:11.000000000 +0000
++++ mpfr-2.3.0-b/VERSION 2007-09-02 23:55:55.000000000 +0000
+@@ -1 +1 @@
+-2.3.0
++2.3.0-p1
+diff -Naurd mpfr-2.3.0-a/mpfr.h mpfr-2.3.0-b/mpfr.h
+--- mpfr-2.3.0-a/mpfr.h 2007-08-29 10:18:11.000000000 +0000
++++ mpfr-2.3.0-b/mpfr.h 2007-09-02 23:55:55.000000000 +0000
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 2
+ #define MPFR_VERSION_MINOR 3
+ #define MPFR_VERSION_PATCHLEVEL 0
+-#define MPFR_VERSION_STRING "2.3.0"
++#define MPFR_VERSION_STRING "2.3.0-p1"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+diff -Naurd mpfr-2.3.0-a/tests/tversion.c mpfr-2.3.0-b/tests/tversion.c
+--- mpfr-2.3.0-a/tests/tversion.c 2007-08-29 10:18:10.000000000 +0000
++++ mpfr-2.3.0-b/tests/tversion.c 2007-09-02 23:55:55.000000000 +0000
+@@ -46,7 +46,7 @@
+ version = mpfr_get_version ();
+
+ /* This test is disabled when a suffix (e.g. -dev) has been defined. */
+-#if 1
++#if 0
+ sprintf (buffer, "%d.%d.%d", MPFR_VERSION_MAJOR, MPFR_VERSION_MINOR,
+ MPFR_VERSION_PATCHLEVEL);
+ if (strcmp (buffer, version) != 0)
+diff -Naurd mpfr-2.3.0-a/version.c mpfr-2.3.0-b/version.c
+--- mpfr-2.3.0-a/version.c 2007-08-29 10:18:11.000000000 +0000
++++ mpfr-2.3.0-b/version.c 2007-09-02 23:55:55.000000000 +0000
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "2.3.0";
++ return "2.3.0-p1";
+ }