summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/popt/popt-1.10.4-r2.ebuild')
-rw-r--r--dev-libs/popt/popt-1.10.4-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/popt/popt-1.10.4-r2.ebuild b/dev-libs/popt/popt-1.10.4-r2.ebuild
new file mode 100644
index 000000000000..6e3dd048a158
--- /dev/null
+++ b/dev-libs/popt/popt-1.10.4-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.10.4-r2.ebuild,v 1.1 2006/10/21 11:45:40 sanchan Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://www.rpm.org/"
+SRC_URI="ftp://jbj.org/pub/rpm-4.4.x/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc-macos ~ppc64 ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+#test fail. I can't figure out why.
+RESTRICT=test
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-lib64.patch
+ use nls || epatch "${FILESDIR}"/${P}-nls.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES README
+}