summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-araneida/cl-araneida-0.9.ebuild')
-rw-r--r--dev-lisp/cl-araneida/cl-araneida-0.9.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
index d22143965162..efb1113bab43 100644
--- a/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
+++ b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild,v 1.1 2005/02/10 09:18:29 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild,v 1.2 2005/02/25 20:10:17 mkennedy Exp $
inherit common-lisp eutils
@@ -11,14 +11,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="net-www/apache
- dev-lisp/cl-split-sequence
+DEPEND="dev-lisp/cl-split-sequence
dev-lisp/cl-net-telent-date"
+RDEPEND="${DEPEND}
+ || ( net-www/apache www-servers/pound )"
CLPACKAGE=araneida
S=${WORKDIR}/araneida_${PV}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+}
+
src_install() {
insinto $CLSOURCEROOT/araneida
doins *.asd *.lisp NEWS
@@ -29,8 +35,8 @@ src_install() {
insinto $CLSOURCEROOT/araneida/doc
doins doc/*.html doc/*.css doc/*.lisp doc/PLAN
common-lisp-system-symlink
- dohtml doc/*.html doc/*.css
- insinto /usr/share/doc/${PF}/examples/
- doins doc/*.lisp
- dodoc doc/*.txt new-dispatch-model
+ dodoc doc/*.txt INSTALL.asdf LICENCE* NEWS Notes README TODO
+ dosym $CLSOURCEROOT/araneida/doc/ \
+ /usr/share/doc/${PF}/html
+ dodoc ${FILESDIR}/README.Gentoo
}