summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild')
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild
new file mode 100644
index 000000000000..16f551b938a3
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.2.ebuild,v 1.1 2009/09/23 02:48:36 beandog Exp $
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit depend.php
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ require_php_with_use pcre
+}
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}