summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch')
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch b/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch
new file mode 100644
index 000000000000..05f2fd9a14a6
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch
@@ -0,0 +1,53 @@
+--- matplotlib-0.84-orig/setup.py 2005-11-25 10:37:14.000000000 +0100
++++ matplotlib-0.84/setup.py 2005-11-25 11:51:46.000000000 +0100
+@@ -165,45 +165,19 @@
+ build_enthought(ext_modules, packages)
+
+ if BUILD_GTK:
+- try:
+- import gtk
+- except ImportError:
+- print 'GTK requires pygtk'
+- BUILD_GTK=0
+- except RuntimeError:
+- print 'pygtk present but import failed'
++ build_gdk(ext_modules, packages, NUMERIX)
+
+-if BUILD_GTK:
+- build_gdk(ext_modules, packages, NUMERIX)
+-
+-if BUILD_GTKAGG:
+- try:
+- import gtk
+- except ImportError:
+- print 'GTKAgg requires pygtk'
+- BUILD_GTKAGG=0
+- except RuntimeError:
+- print 'pygtk present but import failed'
+ if BUILD_GTKAGG:
+ BUILD_AGG = 1
+ build_gtkagg(ext_modules, packages, NUMERIX)
+
+ if BUILD_TKAGG:
+- try: import Tkinter
+- except ImportError: print 'TKAgg requires TkInter'
+- else:
+- BUILD_AGG = 1
+- build_tkagg(ext_modules, packages, NUMERIX)
++ BUILD_AGG = 1
++ build_tkagg(ext_modules, packages, NUMERIX)
+
+ if BUILD_WXAGG:
+- try: import wxPython
+- except ImportError:
+- if BUILD_WXAGG != 'auto':
+- print 'WXAgg\'s accelerator requires wxPython'
+- BUILD_WXAGG = 0
+- else:
+- BUILD_AGG = 1
+- build_wxagg(ext_modules, packages, NUMERIX,
++ BUILD_AGG = 1
++ build_wxagg(ext_modules, packages, NUMERIX,
+ not (isinstance(BUILD_WXAGG, str) # don't about if BUILD_WXAGG
+ and BUILD_WXAGG.lower() == 'auto')) # is "auto"
+