summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygtk/pygtk-0.6.9.ebuild')
-rw-r--r--dev-python/pygtk/pygtk-0.6.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pygtk/pygtk-0.6.9.ebuild b/dev-python/pygtk/pygtk-0.6.9.ebuild
new file mode 100644
index 000000000000..2b0bbcc2008f
--- /dev/null
+++ b/dev-python/pygtk/pygtk-0.6.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.1 2002/06/19 22:08:13 stroke Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ bindings for Python"
+
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/${P}.tar.gz"
+
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+
+DEPEND="virtual/python
+ >=gnome-base/libglade-0.17-r6
+ >=media-libs/imlib-1.8
+ >=media-libs/gdk-pixbuf-0.9.0
+ ( >=x11-libs/gtk+-1.2.10
+ <x11-libs/gtk+-2.0.0 )"
+
+SLOT="1.2"
+src_compile() {
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-libglade-config=/usr/bin/libglade-config \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+# make DESTDIR=${D} install || die
+}
+