summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ldap/python-ldap-9999.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 530a277353a6..8db5b0ae3c0d 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-9999.ebuild,v 1.5 2014/04/09 21:32:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-9999.ebuild,v 1.6 2014/10/17 07:31:18 idella4 Exp $
EAPI=5
@@ -24,13 +24,11 @@ IUSE="doc examples sasl ssl"
# python team: Please do not remove python-ldap-2.3.9 from the tree.
RDEPEND=">=net-nds/openldap-2.4
dev-python/pyasn1[${PYTHON_USEDEP}]
- sasl? ( dev-libs/cyrus-sasl )"
-DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-#bug 458566
-RESTRICT=test
+ sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}] )"
python_prepare_all() {
sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
@@ -50,14 +48,15 @@ python_prepare_all() {
sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
-i setup.cfg || die "error setting up libs in setup.cfg"
+ # set test expected to fail to expectedFailure
+ sed -e "s:^ def test_bad_urls: @unittest.expectedFailure\n def test_bad_urls:" \
+ -i Tests/t_ldapurl.py || die
+
distutils-r1_python_prepare_all
}
python_compile_all() {
- if use doc; then
- cd Doc || die
- sphinx-build -b html -d _build/doctrees . _build/html || die
- fi
+ use doc && emake -C Doc html
}
python_test() {
@@ -68,12 +67,8 @@ python_test() {
}
python_install_all() {
- use doc && local HTML_DOCS=( Doc/_build/html/. )
+ use examples && local EXAMPLES=( Demo/. )
+ use doc && local HTML_DOCS=( Doc/.build/html/. )
distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r Demo
- docompress -x /usr/share/doc/${FP}/Demo
- fi
}