summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashie/hashie-2.0.2.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-2.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-2.0.2.ebuild b/dev-ruby/hashie/hashie-2.0.2.ebuild
new file mode 100644
index 000000000000..a6058464e2a6
--- /dev/null
+++ b/dev-ruby/hashie/hashie-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hashie/hashie-2.0.2.ebuild,v 1.1 2013/03/09 07:20:07 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful."
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}