summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bdelta/bdelta-0.1.0.ebuild')
-rw-r--r--dev-util/bdelta/bdelta-0.1.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-util/bdelta/bdelta-0.1.0.ebuild b/dev-util/bdelta/bdelta-0.1.0.ebuild
index f3bca79fce44..e99002b5a66c 100644
--- a/dev-util/bdelta/bdelta-0.1.0.ebuild
+++ b/dev-util/bdelta/bdelta-0.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bdelta/bdelta-0.1.0.ebuild,v 1.5 2007/08/29 18:02:30 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bdelta/bdelta-0.1.0.ebuild,v 1.6 2009/07/11 17:35:56 vostorga Exp $
-inherit multilib toolchain-funcs
+inherit multilib toolchain-funcs eutils
DESCRIPTION="Binary Delta - Efficient difference algorithm and format"
HOMEPAGE="http://deltup.sourceforge.net"
@@ -17,7 +17,9 @@ src_unpack() {
unpack ${A}
# Set correct libdir
sed -i -e "s:\(LIBDIR=\${PREFIX}/\)lib:\1$(get_libdir):" \
- ${S}/Makefile || die "sed failed"
+ "${S}"/Makefile || die "sed failed"
+ # Fixing ldflags
+ epatch "${FILESDIR}"/${P}-ldflags.patch
}
src_compile() {
@@ -26,6 +28,6 @@ src_compile() {
src_install() {
dodir /usr/$(get_libdir)
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README
}