summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/supertuxkart/files')
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch12
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch2
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch2
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch4
4 files changed, 14 insertions, 6 deletions
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch
new file mode 100644
index 000000000000..d5c038a5f922
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-cmake.patch
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig
++++ CMakeLists.txt
+@@ -128,6 +128,9 @@
+ find_package(OpenGL REQUIRED)
+ include_directories(${OPENGL_INCLUDE_DIR})
+
++find_package(X11 REQUIRED)
++include_directories(${X11_INCLUDE_DIR})
++
+ if(UNIX AND NOT APPLE)
+ find_library(IRRLICHT_XF86VM_LIBRARY Xxf86vm)
+ mark_as_advanced(IRRLICHT_XF86VM_LIBRARY)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
index 071c1b053f7a..647c52245dab 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-gentoo.patch
@@ -1,8 +1,6 @@
gentoo specific hacks because we unbundle the
deps of irrlicht
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 09edd58..1f51a30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,6 @@ add_subdirectory("${PROJECT_SOURCE_DIR}/lib/enet")
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
index f9a5a04d676a..5ce3fff0dd39 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-icon-dest.patch
@@ -4,8 +4,6 @@ Date: Tue Nov 26 22:13:21 2013 +0100
fix icon install dest
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1f51a30..9c07659 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -304,7 +304,9 @@ endif()
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
index 3c120c9b22e2..b1bae371b71d 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-jpeg9.patch
@@ -1,5 +1,5 @@
---- lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp.old 2014-09-25 06:56:46.911153643 +0200
-+++ lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp 2014-09-25 06:55:52.817175916 +0200
+--- lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp.old
++++ lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp
@@ -66,7 +66,7 @@
boolean CImageLoaderJPG::fill_input_buffer (j_decompress_ptr cinfo)
{