summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/violetland/violetland-0.3.2.ebuild')
-rw-r--r--games-action/violetland/violetland-0.3.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/games-action/violetland/violetland-0.3.2.ebuild b/games-action/violetland/violetland-0.3.2.ebuild
deleted file mode 100644
index 1ef826420d20..000000000000
--- a/games-action/violetland/violetland-0.3.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.3.2.ebuild,v 1.1 2011/05/06 16:36:52 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils cmake-utils games
-
-DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
-HOMEPAGE="http://code.google.com/p/violetland/"
-SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
-
-LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="media-libs/libsdl[audio,video]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer[vorbis]
- media-libs/sdl-ttf
- x11-libs/libXext
- x11-libs/libSM
- virtual/opengl
- virtual/glu"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${PN}-v${PV}
-
-src_prepare() {
- sed -i \
- -e "/README_EN.TXT/d" \
- -e "/README_RU.TXT/d" \
- CMakeLists.txt || die "sed failed"
-}
-
-src_configure() {
- mycmakeargs=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
- newicon icon-light.png ${PN}.png
- make_desktop_entry ${PN} VioletLand
- prepgamesdirs
-}