summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/vgba/vgba-3.6.ebuild')
-rw-r--r--games-emulation/vgba/vgba-3.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/vgba/vgba-3.6.ebuild b/games-emulation/vgba/vgba-3.6.ebuild
new file mode 100644
index 000000000000..ca67e8eca0bd
--- /dev/null
+++ b/games-emulation/vgba/vgba-3.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vgba/vgba-3.6.ebuild,v 1.1 2009/10/13 06:39:09 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Gameboy Advance (GBA) emulator for Linux"
+HOMEPAGE="http://www.komkon.org/fms/VGBA/"
+SRC_URI="http://fms.komkon.org/VGBA/VGBA${PV/.}-Linux-Ubuntu-bin.tgz"
+
+LICENSE="VGBA"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="strip"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+
+S=${WORKDIR}
+
+src_install() {
+ into "${GAMES_PREFIX_OPT}"
+ dobin vgba* || die "dobin failed"
+ dohtml VGBA.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "You must run X in 16bit color for the emu to work"
+ echo
+}