summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/xmess/xmess-0.106.ebuild')
-rw-r--r--games-emulation/xmess/xmess-0.106.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/games-emulation/xmess/xmess-0.106.ebuild b/games-emulation/xmess/xmess-0.106.ebuild
index ed4e2b6662ea..584e6d23622c 100644
--- a/games-emulation/xmess/xmess-0.106.ebuild
+++ b/games-emulation/xmess/xmess-0.106.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.14 2012/03/18 13:14:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.15 2012/06/24 16:18:25 tupone Exp $
EAPI=2
inherit flag-o-matic toolchain-funcs eutils games
@@ -146,11 +146,17 @@ EOF
src_compile() {
local disp=0
if use sdl ; then
- emake -j1 DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ emake -j1 DISPLAY_METHOD=SDL \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (SDL)"
disp=1
fi
if use svga ; then
- emake -j1 DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ emake -j1 DISPLAY_METHOD=svgalib \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (svgalib)"
disp=1
fi
if use ggi ; then
@@ -159,7 +165,10 @@ src_compile() {
ewarn "GGI support is currently (${PV}) broken :("
fi
if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
- emake -j1 DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ emake -j1 DISPLAY_METHOD=x11 \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (x11)"
fi
}