summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/picpuz/picpuz-1.9.2.ebuild')
-rw-r--r--games-puzzle/picpuz/picpuz-1.9.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/picpuz/picpuz-1.9.2.ebuild b/games-puzzle/picpuz/picpuz-1.9.2.ebuild
new file mode 100644
index 000000000000..ebe9dbd6421e
--- /dev/null
+++ b/games-puzzle/picpuz/picpuz-1.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/picpuz/picpuz-1.9.2.ebuild,v 1.1 2009/06/11 18:03:32 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="a jigsaw puzzle program"
+HOMEPAGE="http://kornelix.squarespace.com/picpuz/"
+SRC_URI="http://kornelix.squarespace.com/storage/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ DOCDIR=/usr/share/doc/${PF}/html \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* locales || die "doins failed"
+ doicon data/icons/${PN}.png
+ make_desktop_entry ${PN} Picpuz
+ dohtml -r doc/{userguide-en.html,images}
+ dodoc doc/{CHANGES,README,TRANSLATIONS}
+ prepgamesdirs
+}