summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/outerspace/outerspace-0.5.59.ebuild')
-rw-r--r--games-strategy/outerspace/outerspace-0.5.59.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/outerspace/outerspace-0.5.59.ebuild b/games-strategy/outerspace/outerspace-0.5.59.ebuild
new file mode 100644
index 000000000000..efe4f6c89568
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.59.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.1 2007/01/01 12:28:26 tupone Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-$PV
+
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp ${FILESDIR}/${PN} .
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
+ ${PN}
+}
+
+src_install() {
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins -r osc.py lib libsrvr
+ insinto ${GAMES_DATADIR}/${PN}
+ doins -r res
+ dogamesbin ${PN}
+
+ newicon res/icon32.png ${PN}.png
+
+ make_desktop_entry ${PN} ${MY_PN} ${PN}.png
+ prepgamesdirs
+}