summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild')
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild b/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild
index 2d61180f70fa..94097183738b 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild,v 1.8 2012/05/21 18:53:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-2.32.1-r1.ebuild,v 1.9 2012/10/24 07:11:50 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
GNOME_TARBALL_SUFFIX="bz2"
-inherit eutils gnome2 multilib pam virtualx
+inherit autotools eutils gnome2 multilib pam virtualx
DESCRIPTION="Password and keyring managing daemon"
HOMEPAGE="http://live.gnome.org/GnomeKeyring"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE="debug doc pam test"
@@ -27,19 +27,17 @@ RDEPEND=">=dev-libs/glib-2.25:2
>=dev-libs/libtasn1-1"
# valgrind? ( dev-util/valgrind )"
DEPEND="${RDEPEND}
- sys-devel/gettext
+ >=dev-util/gtk-doc-am-1.9
>=dev-util/intltool-0.35
- virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.9 )"
+ sys-devel/gettext
+ virtual/pkgconfig"
PDEPEND="gnome-base/libgnome-keyring"
-# eautoreconf needs:
-# >=dev-util/gtk-doc-am-1.9
# tests fail in several ways, they should be fixed in the next cycle (bug #340283),
# revisit then.
RESTRICT="test"
-pkg_setup() {
+src_prepare() {
DOCS="AUTHORS ChangeLog NEWS README"
G2CONF="${G2CONF}
$(use_enable debug)
@@ -52,9 +50,10 @@ pkg_setup() {
--enable-gpg-agent
--with-gtk=2.0"
# $(use_enable valgrind)
-}
-src_prepare() {
+ epatch "${FILESDIR}/${P}-glib-2.32.patch"
+ eautoreconf
+
gnome2_src_prepare
# Remove silly CFLAGS