summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/orbit/orbit-2.10.3.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.10.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnome-base/orbit/orbit-2.10.3.ebuild b/gnome-base/orbit/orbit-2.10.3.ebuild
new file mode 100644
index 000000000000..4844d922163f
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.10.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.10.3.ebuild,v 1.1 2004/08/21 14:56:09 obz Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+IUSE="doc ssl"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ~ppc alpha sparc hppa amd64 ia64 ~mips ~ppc64"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.7.4
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog COPYING* README* HACKING INSTALL NEWS TODO MAINTAINERS"