summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/zenity/zenity-2.6.3.ebuild')
-rw-r--r--gnome-extra/zenity/zenity-2.6.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnome-extra/zenity/zenity-2.6.3.ebuild b/gnome-extra/zenity/zenity-2.6.3.ebuild
new file mode 100644
index 000000000000..073f3c47bd4d
--- /dev/null
+++ b/gnome-extra/zenity/zenity-2.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-2.6.3.ebuild,v 1.1 2004/09/13 16:29:42 obz Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="commandline dialog tool for gnome"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.3.1
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomecanvas-2
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ app-text/scrollkeeper
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # Don't set the UTF-8 codeset before parsing command line arguments.
+ # Closes bug #45204.
+ # Slightly altered for 2.6.3, removed the obsolete first hunk
+ epatch ${FILESDIR}/${P}-utf8_fix.patch
+
+}
+