summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.3.0.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.3.0.ebuild b/kde-base/dolphin/dolphin-4.3.0.ebuild
new file mode 100644
index 000000000000..c10642fd6e1d
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.3.0.ebuild,v 1.1 2009/08/03 23:15:30 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +handbook +semantic-desktop thumbnail"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop=]
+ >=kde-base/libkonq-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kfind-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+PDEPEND="
+ thumbnail? ( >=kde-base/mplayerthumbs-${PV}:${SLOT}[kdeprefix=] )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}