summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kontact/kontact-4.2.2.ebuild')
-rw-r--r--kde-base/kontact/kontact-4.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-4.2.2.ebuild b/kde-base/kontact/kontact-4.2.2.ebuild
new file mode 100644
index 000000000000..7bd844896af9
--- /dev/null
+++ b/kde-base/kontact/kontact-4.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.2.2.ebuild,v 1.1 2009/04/11 23:44:02 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+DEPEND="
+ app-crypt/gpgme
+ >=kde-base/kontactinterfaces-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/kmobiletools
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ kontactinterfaces/
+"