summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kauth/kauth-5.5.0.ebuild')
-rw-r--r--kde-frameworks/kauth/kauth-5.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/kauth-5.5.0.ebuild b/kde-frameworks/kauth/kauth-5.5.0.ebuild
new file mode 100644
index 000000000000..5cc3a742b99f
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kauth/kauth-5.5.0.ebuild,v 1.1 2014/12/17 21:24:22 mrueg Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS=" ~amd64"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ policykit? ( sys-auth/polkit-qt[qt5] )
+"
+DEPEND="${RDEPEND}
+ nls? ( dev-qt/linguist-tools:5 )
+"
+#PDEPEND="policykit? ( sys-auth/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt-1)
+ )
+
+ kde5_src_configure
+}