summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pinta/pinta-9999.ebuild')
-rw-r--r--media-gfx/pinta/pinta-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/media-gfx/pinta/pinta-9999.ebuild b/media-gfx/pinta/pinta-9999.ebuild
index c74ecea91194..f1e3d2b0d13c 100644
--- a/media-gfx/pinta/pinta-9999.ebuild
+++ b/media-gfx/pinta/pinta-9999.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pinta/pinta-9999.ebuild,v 1.5 2013/02/07 22:27:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pinta/pinta-9999.ebuild,v 1.6 2013/03/21 17:03:38 hasufell Exp $
-EAPI=4
+EAPI=5
-inherit autotools fdo-mime git-2 mono
+inherit autotools fdo-mime gnome2-utils git-2 mono
DESCRIPTION="Simple Painting for Gtk"
HOMEPAGE="http://pinta-project.com"
-SRC_URI=""
-
EGIT_REPO_URI="git://github.com/PintaProject/Pinta.git"
LICENSE="MIT CC-BY-3.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
COMMON_DEPEND="dev-dotnet/atk-sharp:2
dev-dotnet/gdk-sharp:2
@@ -30,20 +27,32 @@ RDEPEND="${COMMON_DEPEND}
x11-themes/gnome-icon-theme"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
- virtual/pkgconfig
- sys-devel/gettext"
+ virtual/pkgconfig"
src_prepare() {
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/po ; echo *.po) ; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ sed -i -e "/po\/${i%.po}.po/{N;N;d;}" Pinta.Install.proj || die
+ fi
+ done
+ fi
eautoreconf
- intltoolize --copy --automake --force || die "intltoolize failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
}
pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
+ gnome2_icon_cache_update
}
pkg_postrm() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
+ gnome2_icon_cache_update
}