summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/celt/celt-0.7.0-r1.ebuild')
-rw-r--r--media-libs/celt/celt-0.7.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/celt/celt-0.7.0-r1.ebuild b/media-libs/celt/celt-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..d28cbb10f916
--- /dev/null
+++ b/media-libs/celt/celt-0.7.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/celt-0.7.0-r1.ebuild,v 1.1 2009/11/20 00:42:41 tgurr Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications."
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ogg"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with ogg ogg /usr)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README TODO || die "dodoc failed."
+
+ # needed until upstream cares about proper library versioning
+ dosym /usr/$(get_libdir)/libcelt.so.0.0.0 /usr/$(get_libdir)/libcelt.so.${PV}
+
+ find "${D}" -name '*.la' -delete
+}