summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpglen/mpglen-0.1.ebuild')
-rw-r--r--media-video/mpglen/mpglen-0.1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/media-video/mpglen/mpglen-0.1.ebuild b/media-video/mpglen/mpglen-0.1.ebuild
index e8470a51f478..0ec0cedc8d4a 100644
--- a/media-video/mpglen/mpglen-0.1.ebuild
+++ b/media-video/mpglen/mpglen-0.1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpglen/mpglen-0.1.ebuild,v 1.4 2005/09/03 23:18:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpglen/mpglen-0.1.ebuild,v 1.5 2006/03/07 16:45:06 flameeyes Exp $
+
+inherit toolchain-funcs flag-o-matic
IUSE=""
-MY_S=${WORKDIR}/${PN}
+S=${WORKDIR}/${PN}
DESCRIPTION="A program to scan through a MPEG file and count the number of GOPs and frames"
HOMEPAGE="http://www.iamnota.net/mpglen/"
@@ -14,15 +16,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's:gcc .* -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' ${S}/Makefile
+}
src_compile () {
- cd ${MY_S} || die
- emake || die
+ append-lfs-flags
+ emake CC="$(tc-getCC)" || die
}
src_install () {
- cd ${MY_S} || die
dobin ${PN} || die
dodoc AUTHORS Changelog README || die
}