summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bwm-ng/bwm-ng-0.6.ebuild')
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.ebuild
new file mode 100644
index 000000000000..e984fceb1abb
--- /dev/null
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwm-ng/bwm-ng-0.6.ebuild,v 1.1 2007/10/21 12:14:13 hollow Exp $
+
+DESCRIPTION="Bandwidth Monitor NG is a small and simple console-based bandwidth monitor for Linux, BSD, and Mac OS X"
+SRC_URI="http://www.gropp.org/bwm-ng/${P}.tar.gz"
+HOMEPAGE="http://www.gropp.org/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="html csv"
+
+DEPEND=">=sys-libs/ncurses-5.4-r4
+ >=sys-apps/net-tools-1.60-r1"
+
+src_compile() {
+ econf \
+ --with-ncurses \
+ $(use_enable html) \
+ $(use_enable csv) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS
+}