summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup/libsoup-1.99.20.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-1.99.20.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-1.99.20.ebuild b/net-libs/libsoup/libsoup-1.99.20.ebuild
new file mode 100644
index 000000000000..a259b804020b
--- /dev/null
+++ b/net-libs/libsoup/libsoup-1.99.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-1.99.20.ebuild,v 1.1 2003/05/07 11:18:18 liquidx Exp $
+
+#IUSE="ssl"
+IUSE=""
+
+inherit gnome.org libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="2"
+RDEPEND=">=dev-libs/glib-2.0
+ dev-libs/openssl"
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ dev-libs/popt
+ ${RDEPEND}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+
+ # current build system deems ssl as NOT AN OPTION.
+ # use ssl && myconf="--enable-ssl --enable-openssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING* ChangeLog README* TODO
+}