summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtorrent/files')
-rw-r--r--net-libs/libtorrent/files/0.3.2-rtorrent.patch7
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.3.21
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.3.1-client.patch15
3 files changed, 23 insertions, 0 deletions
diff --git a/net-libs/libtorrent/files/0.3.2-rtorrent.patch b/net-libs/libtorrent/files/0.3.2-rtorrent.patch
new file mode 100644
index 000000000000..5b8f485c2043
--- /dev/null
+++ b/net-libs/libtorrent/files/0.3.2-rtorrent.patch
@@ -0,0 +1,7 @@
+--- libtorrent-0.3.2/client/rtorrent.cc 2004-08-18 13:00:42.692968144 -0500
++++ libtorrent-0.3.2/client/rtorrent.cc 2004-08-18 13:00:48.763045352 -0500
+@@ -1,3 +1,4 @@
++#include <cerrno>
+ #include <iostream>
+ #include <fstream>
+ #include <signal.h>
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.3.2 b/net-libs/libtorrent/files/digest-libtorrent-0.3.2
new file mode 100644
index 000000000000..d80bf6debcfc
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.3.2
@@ -0,0 +1 @@
+MD5 0019b862d4d196bebe565b8db6f41ee9 libtorrent-0.3.2.tar.gz 355731
diff --git a/net-libs/libtorrent/files/libtorrent-0.3.1-client.patch b/net-libs/libtorrent/files/libtorrent-0.3.1-client.patch
new file mode 100644
index 000000000000..cf5990fae3a4
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.3.1-client.patch
@@ -0,0 +1,15 @@
+diff -ur libtorrent-0.3.1.orig/client/Makefile libtorrent-0.3.1/client/Makefile
+--- libtorrent-0.3.1.orig/client/Makefile 2004-08-11 03:47:07.000000000 -0300
++++ libtorrent-0.3.1/client/Makefile 2004-08-17 09:28:03.060190224 -0300
+@@ -1,8 +1,8 @@
+ OBJECTS = http.o display.o download.o rtorrent.o
+
+-LIBS = -ltorrent -lncurses -lcrypto `pkg-config --libs sigc++-2.0 libtorrent`
++LIBS = -ltorrent -lncurses -lcrypto `pkg-config --libs sigc++-2.0`
+
+-CFLAGS = -Wall -O3 -g `pkg-config --cflags sigc++-2.0 libtorrent`
++CFLAGS = -Wall -O3 -g `pkg-config --cflags sigc++-2.0` -I .. -L ../torrent/.libs
+
+ all: $(OBJECTS)
+ g++ $(CFLAGS) -o rtorrent $(OBJECTS) $(LIBS)
+