summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pump/pump-0.8.24.ebuild')
-rw-r--r--net-misc/pump/pump-0.8.24.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-misc/pump/pump-0.8.24.ebuild b/net-misc/pump/pump-0.8.24.ebuild
index 695212d49614..37712834ccdb 100644
--- a/net-misc/pump/pump-0.8.24.ebuild
+++ b/net-misc/pump/pump-0.8.24.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24.ebuild,v 1.8 2006/09/26 05:37:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24.ebuild,v 1.9 2007/12/29 20:04:20 phreak Exp $
inherit eutils
@@ -33,6 +33,10 @@ src_unpack() {
# Enable the creation of /etc/ntp.conf and the --no-ntp option
epatch "${FILESDIR}/pump-${PV}-gentoo.patch"
+ # Add an if defined around the definition of foo, just like in popt.h
+ # Fixes #201958
+ epatch "${FILESDIR}/${P}-redefinition.patch"
+
# Only install specific po files if LINGUAS is set
if [[ -n ${LINGUAS} ]]; then
cd po