summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/vconfig')
-rw-r--r--net-misc/vconfig/Manifest4
-rw-r--r--net-misc/vconfig/files/digest-vconfig-1.7-r22
-rw-r--r--net-misc/vconfig/vconfig-1.7-r2.ebuild46
3 files changed, 50 insertions, 2 deletions
diff --git a/net-misc/vconfig/Manifest b/net-misc/vconfig/Manifest
index f359a182ba14..af6514caaf9d 100644
--- a/net-misc/vconfig/Manifest
+++ b/net-misc/vconfig/Manifest
@@ -1,7 +1,7 @@
MD5 4560ef0508c8f9eaa77694ba26b4c9ce vconfig-1.7-r1.ebuild 1319
MD5 6556f5aceb3d8669a21e36a4b116f603 vconfig-1.7.ebuild 964
-MD5 5a44509815ba413bacc767c1553879e0 vconfig-1.7-r2.ebuild 1425
-MD5 aa5a7e8fa1bacf84e3a4b2d14cff0c21 ChangeLog 892
+MD5 a75133e4c8ce5df162061c317a5e61e9 vconfig-1.7-r2.ebuild 1425
+MD5 fd54bd5bd5963e23b08483770e231c49 ChangeLog 1123
MD5 da7c34aae19ef948be141f51591982e0 metadata.xml 497
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7 59
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7-r1 59
diff --git a/net-misc/vconfig/files/digest-vconfig-1.7-r2 b/net-misc/vconfig/files/digest-vconfig-1.7-r2
new file mode 100644
index 000000000000..5eb4b457386b
--- /dev/null
+++ b/net-misc/vconfig/files/digest-vconfig-1.7-r2
@@ -0,0 +1,2 @@
+MD5 5c32d84f290162322e16097ff50865bb vlan.1.7.tar.gz 90041
+MD5 d7c76b704a110225e05e90bdc4883955 vconfig-1.7-gcc33-multiline.patch 3102
diff --git a/net-misc/vconfig/vconfig-1.7-r2.ebuild b/net-misc/vconfig/vconfig-1.7-r2.ebuild
new file mode 100644
index 000000000000..9da250a505c8
--- /dev/null
+++ b/net-misc/vconfig/vconfig-1.7-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/vconfig-1.7-r2.ebuild,v 1.1 2003/09/25 03:02:10 robbat2 Exp $
+
+MY_PN="vlan"
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="802.1Q vlan control utility"
+HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
+SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz
+mirror://gentoo/vconfig-1.7-gcc33-multiline.patch"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~arm"
+IUSE="static"
+DEPEND=">=sys-kernel/linux-headers-2.4.14"
+RDEPEND=">=virtual/kernel-2.4.14"
+
+src_unpack() {
+ unpack ${MY_PN}.${PV}.tar.gz
+ epatch ${DISTDIR}/vconfig-1.7-gcc33-multiline.patch
+}
+
+src_compile() {
+ use static && LDFLAGS="${LDFLAGS} -static"
+ emake CC="${CC}" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ into /
+ dosbin vconfig || die "dosbin error"
+
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test.pl
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:g" -i vlan_test2.pl
+
+ doman vconfig.8 || die "doman error"
+ dohtml howto.html vlan.html || die "dohtml error"
+ dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
+}
+
+pkg_postinst() {
+ einfo "802.1Q VLAN support is now in the linux kernel as of 2.4.14."
+ ewarn "MTU problems exist for many ethernet drivers."
+ ewarn "Reduce the MTU on the interface to 1496 to work around them."
+
+}