summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/mutella/mutella-0.4.5.ebuild')
-rw-r--r--net-p2p/mutella/mutella-0.4.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-p2p/mutella/mutella-0.4.5.ebuild b/net-p2p/mutella/mutella-0.4.5.ebuild
new file mode 100644
index 000000000000..04d26411d9ba
--- /dev/null
+++ b/net-p2p/mutella/mutella-0.4.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.4.5.ebuild,v 1.1 2004/10/05 16:42:31 squinky86 Exp $
+
+DESCRIPTION="Text-mode gnutella client"
+SRC_URI="mirror://sourceforge/mutella/${P}.tar.gz"
+HOMEPAGE="http://mutella.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug"
+DEPEND="virtual/libc
+ sys-libs/readline"
+
+src_compile() {
+ econf --enable-optimization \
+ `use_enable debug` || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL LICENSE KNOWN-BUGS README TODO
+}