summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/galculator/galculator-1.3.4.ebuild')
-rw-r--r--sci-calculators/galculator/galculator-1.3.4.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sci-calculators/galculator/galculator-1.3.4.ebuild b/sci-calculators/galculator/galculator-1.3.4.ebuild
index 8f60ae3ed95c..68911168b941 100644
--- a/sci-calculators/galculator/galculator-1.3.4.ebuild
+++ b/sci-calculators/galculator/galculator-1.3.4.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/galculator/galculator-1.3.4.ebuild,v 1.6 2010/01/11 17:46:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/galculator/galculator-1.3.4.ebuild,v 1.7 2010/06/22 12:56:56 ssuominen Exp $
-EAPI="2"
+EAPI=2
DESCRIPTION="GTK+ based algebraic and RPN calculator."
HOMEPAGE="http://galculator.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="alpha amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="gnome"
+IUSE=""
RDEPEND=">=x11-libs/gtk+-2.6
- >=gnome-base/libglade-2
- gnome? ( gnome-base/gnome-desktop )"
+ >=gnome-base/libglade-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- use gnome || sed -i -e 's:gnome-calc2.png:calc:' "${S}"/galculator.desktop.in
# Fix tests
echo ui/*.glade | tr -t ' ' '\n' >> po/POTFILES.in
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
}