summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/clapack/clapack-3.2.1-r4.ebuild')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r4.ebuild b/sci-libs/clapack/clapack-3.2.1-r4.ebuild
new file mode 100644
index 000000000000..ed5db6298a09
--- /dev/null
+++ b/sci-libs/clapack/clapack-3.2.1-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r4.ebuild,v 1.1 2011/04/30 09:50:09 scarabeus Exp $
+
+EAPI=4
+
+inherit base cmake-utils
+
+DESCRIPTION="f2c'ed version of LAPACK"
+HOMEPAGE="http://www.netlib.org/clapack/"
+SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/libf2c-20090407-r1
+ virtual/blas"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-CMAKE
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_include_file.patch"
+ "${FILESDIR}/${P}-noblasf2c.patch"
+)
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
+ cmake-utils_src_configure
+}