summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/yacas/yacas-1.0.56.ebuild')
-rw-r--r--sci-mathematics/yacas/yacas-1.0.56.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sci-mathematics/yacas/yacas-1.0.56.ebuild b/sci-mathematics/yacas/yacas-1.0.56.ebuild
deleted file mode 100644
index d44c00ec1f2a..000000000000
--- a/sci-mathematics/yacas/yacas-1.0.56.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.56.ebuild,v 1.3 2005/10/02 02:47:45 ribosome Exp $
-
-inherit eutils
-
-IUSE="gmp"
-
-DESCRIPTION="very powerful general purpose Computer Algebra System"
-HOMEPAGE="http://yacas.sourceforge.net/"
-SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz
- mirror://gentoo/${P}.patch.bz2
- http://dev.gentoo.org/~phosphan/${P}.patch.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~amd64"
-
-DEPEND="virtual/libc
- >=sys-apps/sed-4
- gmp? ( >=dev-libs/gmp-4 ) "
-
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${P}.patch
- epatch "${FILESDIR}"/opengl-gcc3.4.patch
-}
-
-src_compile() {
- local myconf
- if use gmp ; then
- myconf="--with-numlib=gmp"
- fi
- econf ${myconf} || die "./configure failed"
- emake || die
-}
-
-src_install() {
- # a very strange Makefile's, that do not honor standard wrappings :(
- find -name Makefile |xargs sed -i -e "s:datadir = /usr/share:datadir = ${D}/usr/share:"
- cd manmake
- sed -i -e "s:htmldir = :htmldir = ${D}:" -e "s:psdir = :psdir = ${D}:" Makefile
- cd "${S}"
-
- DESTDIR="${D}" make install-strip || die
-
- dodoc AUTHORS INSTALL NEWS README TODO
- mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
- rmdir "${D}"/usr/include/
- sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
- -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
- -i "${D}"/usr/share/${PN}/yacasinit.ys || die
-}