summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ed/ed-1.2.ebuild')
-rw-r--r--sys-apps/ed/ed-1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-1.2.ebuild b/sys-apps/ed/ed-1.2.ebuild
new file mode 100644
index 000000000000..ca12b1c1bf25
--- /dev/null
+++ b/sys-apps/ed/ed-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-1.2.ebuild,v 1.1 2009/02/02 05:00:27 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2-build.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ # custom configure script ... econf wont work
+ ./configure \
+ --prefix=/ \
+ --datadir=/usr/share \
+ ${EXTRA_ECONF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}