summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/i2c/i2c-2.7.0.ebuild')
-rw-r--r--sys-apps/i2c/i2c-2.7.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-apps/i2c/i2c-2.7.0.ebuild b/sys-apps/i2c/i2c-2.7.0.ebuild
index 65c90857870e..b9146f72dbe0 100644
--- a/sys-apps/i2c/i2c-2.7.0.ebuild
+++ b/sys-apps/i2c/i2c-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.7 2003/10/03 15:09:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.8 2003/10/14 21:02:42 plasmaroo Exp $
DESCRIPTION="I2C Bus support"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -8,11 +8,16 @@ SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ~ppc"
+KEYWORDS="x86 amd64 alpha ~ppc"
DEPEND="virtual/linux-sources"
src_compile() {
+
+ cd kernel;
+ epatch ${FILESDIR}/i2c-2.8.0-alphaCompile.patch > /dev/null;
+ cd ..;
+
if [ ! `emake LINUX_INCLUDE_DIR=/usr/include/linux clean all` ] ; then
eerror "i2c requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"