summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r3.ebuild73
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r4.ebuild73
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r5.ebuild80
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r6.ebuild72
-rw-r--r--sys-apps/hdparm/hdparm-3.9-r3.ebuild24
-rw-r--r--sys-apps/ipchains/ipchains-1.3.10-r1.ebuild47
-rw-r--r--sys-apps/iproute2/iproute2-2.4.7.ebuild95
-rw-r--r--sys-apps/iptables/iptables-1.2.2.ebuild32
-rw-r--r--sys-apps/iptables/iptables-1.2.3.ebuild4
9 files changed, 95 insertions, 405 deletions
diff --git a/sys-apps/gzip/gzip-1.2.4a-r3.ebuild b/sys-apps/gzip/gzip-1.2.4a-r3.ebuild
deleted file mode 100644
index e5fbffb38418..000000000000
--- a/sys-apps/gzip/gzip-1.2.4a-r3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r3.ebuild,v 1.1 2001/02/27 16:44:48 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard GNU compressor"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
- ftp://prep.ai.mit.edu/gnu/gzip/${A}"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
- --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static ${MAKEOPTS}
- fi
-}
-
-src_install() {
-
- dodir /usr/bin /usr/share/man/man1
- try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
-
- cd ${D}/bin
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- cp ${i} ${i}.orig
- sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
- rm ${i}.orig
- chmod 755 ${i}
- done
-
- if [ -z "`use build`" ]
- then
- cd ${D}/usr/share/man/man1
-
- for i in gzexe gzip zcat zcmp zdiff zforce \
- zgrep zmore znew
- do
- rm ${i}.1
- ln -s gunzip.1.gz ${i}.1.gz
- done
-
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
-
- dodoc ChangeLog COPYING NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
-
-
-
-
diff --git a/sys-apps/gzip/gzip-1.2.4a-r4.ebuild b/sys-apps/gzip/gzip-1.2.4a-r4.ebuild
deleted file mode 100644
index 633101a22282..000000000000
--- a/sys-apps/gzip/gzip-1.2.4a-r4.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard GNU compressor"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
- ftp://prep.ai.mit.edu/gnu/gzip/${A}"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
- --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static ${MAKEOPTS}
- fi
-}
-
-src_install() {
-
- dodir /usr/bin /usr/share/man/man1
- try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
-
- cd ${D}/bin
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- cp ${i} ${i}.orig
- sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
- rm ${i}.orig
- chmod 755 ${i}
- done
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- cd ${D}/usr/share/man/man1
-
- for i in gzexe gzip zcat zcmp zdiff zforce \
- zgrep zmore znew
- do
- rm ${i}.1
- ln -s gunzip.1.gz ${i}.1.gz
- done
-
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
-
- dodoc ChangeLog COPYING NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
-
-
-
-
diff --git a/sys-apps/gzip/gzip-1.2.4a-r5.ebuild b/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
deleted file mode 100644
index 7ce7e3377bd9..000000000000
--- a/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Chad Huneycutt <chad.huneycutt@acm.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r5.ebuild,v 1.2 2001/08/12 18:32:42 chadh Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard GNU compressor"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
- ftp://prep.ai.mit.edu/gnu/gzip/${A}"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
- cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-}
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
- --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static ${MAKEOPTS}
- fi
-}
-
-src_install() {
-
- dodir /usr/bin /usr/share/man/man1
- try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
-
- cd ${D}/bin
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- cp ${i} ${i}.orig
- sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
- rm ${i}.orig
- chmod 755 ${i}
- done
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- cd ${D}/usr/share/man/man1
-
- for i in gzexe gzip zcat zcmp zdiff zforce \
- zgrep zmore znew
- do
- rm ${i}.1
- ln -s gunzip.1.gz ${i}.1.gz
- done
-
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
-
- dodoc ChangeLog COPYING NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
-
-
-
-
diff --git a/sys-apps/gzip/gzip-1.2.4a-r6.ebuild b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
index 09995ae41049..0baa06c9c780 100644
--- a/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
+++ b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
@@ -1,16 +1,12 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Chad Huneycutt <chad.huneycutt@acm.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r6.ebuild,v 1.1 2001/08/14 01:59:52 chadh Exp $
+# Author Daniel Robbins <drobbins@gentoo.org>, Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r6.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Standard GNU compressor"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
- ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${P}.tar.gz ftp://prep.ai.mit.edu/gnu/gzip/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
@@ -21,29 +17,14 @@ src_unpack() {
}
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
- --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static ${MAKEOPTS}
- fi
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf} || die
+ emake || die
}
src_install() {
-
dodir /usr/bin /usr/share/man/man1
- try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
-
+ make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install || die
cd ${D}/bin
for i in gzexe zforce zgrep zmore znew zcmp
do
@@ -52,27 +33,22 @@ src_install() {
rm ${i}.orig
chmod 755 ${i}
done
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- cd ${D}/usr/share/man/man1
-
- for i in gzexe gzip zcat zcmp zdiff zforce \
- zgrep zmore znew
- do
- rm ${i}.1
- ln -s gunzip.1.gz ${i}.1.gz
- done
-
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
-
- dodoc ChangeLog COPYING NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
+ if [ -z "`use build`" ]
+ then
+ cd ${D}/usr/share/man/man1
+ for i in gzexe gzip zcat zcmp zdiff zforce zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
}
diff --git a/sys-apps/hdparm/hdparm-3.9-r3.ebuild b/sys-apps/hdparm/hdparm-3.9-r3.ebuild
index 3c9241d3d75e..1f141fada7b8 100644
--- a/sys-apps/hdparm/hdparm-3.9-r3.ebuild
+++ b/sys-apps/hdparm/hdparm-3.9-r3.ebuild
@@ -1,35 +1,29 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-3.9-r3.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-3.9-r3.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Utility to change hard drive performance parameters"
-SRC_URI="http://metalab.unc.edu/pub/Linux/system/hardware/${A}"
+SRC_URI="http://metalab.unc.edu/pub/Linux/system/hardware/${P}.tar.gz"
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" -e "s:-s::" \
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:-s::" \
Makefile.orig > Makefile
-
}
src_compile() {
- try pmake all
+ emake all || die
}
src_install() {
-
-
dosbin hdparm
doman hdparm.8
dodoc hdparm-*.lsm Changelog
-
}
diff --git a/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
index 916a2313b31e..5345e89955e9 100644
--- a/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
+++ b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
@@ -1,43 +1,36 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="2.2 kernel equivalent of ipfwadm"
-SRC_URI="http://netfilter.kernelnotes.org/ipchains/${A}"
+DESCRIPTION="legacy Linux firewall/packet mangling tools"
+SRC_URI="http://netfilter.kernelnotes.org/ipchains/${P}.tar.gz"
HOMEPAGE="http://netfilter.filewatcher.org/ipchains/"
-
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- mv Makefile Makefile.orig
- sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/libipfwc
- mv Makefile Makefile.orig
- sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/libipfwc
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
}
src_compile() {
-
- try make clean
- try make ${MAKEOPTS} all
-
+ make clean || die
+ emake all || die
}
src_install() {
-
- into /
- dosbin ipchains
- doman ipfw.4 ipchains.8
- dodoc COPYING README
- docinto ps
- dodoc ipchains-quickref.ps
-
+ into /
+ dosbin ipchains
+ doman ipfw.4 ipchains.8
+ dodoc COPYING README
+ docinto ps
+ dodoc ipchains-quickref.ps
}
diff --git a/sys-apps/iproute2/iproute2-2.4.7.ebuild b/sys-apps/iproute2/iproute2-2.4.7.ebuild
index cade5336cdce..d35e89da66e8 100644
--- a/sys-apps/iproute2/iproute2-2.4.7.ebuild
+++ b/sys-apps/iproute2/iproute2-2.4.7.ebuild
@@ -1,72 +1,57 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7.ebuild,v 1.2 2001/10/01 22:35:24 drobbins Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7.ebuild,v 1.3 2001/10/06 17:13:29 drobbins Exp $
-A=iproute2-2.4.7-now-ss010824.tar.gz
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
-SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
-
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/iproute2-2.4.7-now-ss010824.tar.gz"
DEPEND="virtual/glibc"
-# if we include tex, it _could_ lead to X being pulled in during emerge system.
-# tex? ( app-text/tetex )"
src_unpack() {
-
- unpack ${A}
-
- # we now install the kernel headers used for compiling glibc, directly into
- # /usr/include/{asm,linux}; which is a good thing(tm). we need to patch
- # iproute2's Makefile to thusly compile without a /usr/src/linux tree.
- # ~woodchip
- cd ${S}
- patch -p0 < ${FILESDIR}/makefile-kernel-includes.diff || die
-
- # omits this protocol support from being built: "__PF(PUP,pup)"
- # the package builds fine without this patch. is there another concern?
- # ~woodchip
- # cd ${S}/lib
- # cp ll_proto.c ll_proto.c.orig
- # sed -e "36 d" ll_proto.c.orig > ll_proto.c
-
- # why was this commented out? were the programs segfaulting/not working?
- # they seem ok here when i compile with optimisations, so im reenabling
- # this patch. if theres problems, will glady change back. ~woodchip
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
-
- # this next thing is required to enable diffserv (ATM support doesn't compile right now)
- # cp Config Config.orig
- # sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
-
+ unpack ${A}
+ # we now install the kernel headers used for compiling glibc, directly into
+ # /usr/include/{asm,linux}; which is a good thing(tm). we need to patch
+ # iproute2's Makefile to thusly compile without a /usr/src/linux tree.
+ # ~woodchip
+ cd ${S}
+ patch -p0 < ${FILESDIR}/makefile-kernel-includes.diff || die
+
+ # omits this protocol support from being built: "__PF(PUP,pup)"
+ # the package builds fine without this patch. is there another concern?
+ # ~woodchip
+ # cd ${S}/lib
+ # cp ll_proto.c ll_proto.c.orig
+ # sed -e "36 d" ll_proto.c.orig > ll_proto.c
+
+ # why was this commented out? were the programs segfaulting/not working?
+ # they seem ok here when i compile with optimisations, so im reenabling
+ # this patch. if theres problems, will glady change back. ~woodchip
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+
+ # this next thing is required to enable diffserv (ATM support doesn't compile right now)
+ # cp Config Config.orig
+ # sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
+
#this fix optionally disables the IEEE1394 definition if it is not in the kernel headers
#This allows this pkg to work with earlier 2.4 kernel headers.
cp ${FILESDIR}/ll_types.c ${S}/lib
}
src_compile() {
-
- make ${MAKEOPTS} || die
- # if [ "`use tex`" ] ; then
- # cd doc
- # make || die
- # fi
+ emake || die
}
src_install() {
-
- cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
- cd ${S}/tc ; dosbin tc
-
- cd ${S} ; dodoc README* RELNOTES
- docinto examples/diffserv ; dodoc examples/diffserv/*
- docinto examples ; dodoc examples/*
-
- dodir /etc/iproute2
- insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
-
- if [ "`use tex`" ] ; then
- docinto ps ; dodoc doc/*.ps
- fi
+ cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc ; dosbin tc
+ cd ${S} ; dodoc README* RELNOTES
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+ if [ "`use tex`" ] ; then
+ docinto ps ; dodoc doc/*.ps
+ fi
}
diff --git a/sys-apps/iptables/iptables-1.2.2.ebuild b/sys-apps/iptables/iptables-1.2.2.ebuild
deleted file mode 100644
index d9c9f209cb29..000000000000
--- a/sys-apps/iptables/iptables-1.2.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.2.ebuild,v 1.1 2001/05/09 11:09:31 achim Exp $
-
-A=${P}.tar.bz2
-S=${WORKDIR}/${P}
-DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
-SRC_URI="http://netfilter.samba.org/${A}"
-
-DEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local:/usr:g" Makefile.orig > Makefile
-}
-
-src_compile() {
- #I had a problem with pmake - DR
- try make
-}
-
-
-src_install() {
- dodir /usr/lib /usr/share/man/man8 /usr/sbin
- try make LIBDIR=${D}/usr/lib BINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man install
- dodoc COPYING KNOWN_BUGS
-}
-
-
diff --git a/sys-apps/iptables/iptables-1.2.3.ebuild b/sys-apps/iptables/iptables-1.2.3.ebuild
index b9f52897d1b0..5f4eee8ad0f4 100644
--- a/sys-apps/iptables/iptables-1.2.3.ebuild
+++ b/sys-apps/iptables/iptables-1.2.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.3.ebuild,v 1.1 2001/09/06 20:21:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.3.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
@@ -18,7 +18,7 @@ src_unpack() {
}
src_compile() {
- #I had a problem with emake - DR
+ #I had a problem with emake - DR
make || die
}