summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ploop/ploop-1.6.ebuild')
-rw-r--r--sys-cluster/ploop/ploop-1.6.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-cluster/ploop/ploop-1.6.ebuild b/sys-cluster/ploop/ploop-1.6.ebuild
new file mode 100644
index 000000000000..7ca424b22e31
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.6.ebuild,v 1.1 2013/02/22 14:01:33 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ epatch "${FILESDIR}/ploop-1.2-soname.patch"
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+ use static-libs || rm "${D}/usr/$(get_libdir)/libploop.a" || die 'remove static lib failed'
+
+ systemd_newtmpfilesd "${FILESDIR}/ploop.tmpfiles" ploop.conf
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab061.1"
+ elog "2. DiskDescriptor.xml created by older ploop versions are converted to current format"
+}