summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gettext/gettext-0.18.3.2.ebuild')
-rw-r--r--sys-devel/gettext/gettext-0.18.3.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/gettext/gettext-0.18.3.2.ebuild b/sys-devel/gettext/gettext-0.18.3.2.ebuild
index a453ca946a4e..f88a6fbf2acb 100644
--- a/sys-devel/gettext/gettext-0.18.3.2.ebuild
+++ b/sys-devel/gettext/gettext-0.18.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.3.2.ebuild,v 1.1 2014/01/16 13:35:36 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.18.3.2.ebuild,v 1.2 2014/01/18 06:13:43 vapier Exp $
EAPI="4"
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE="acl -cvs doc emacs git java nls +cxx ncurses openmp static-libs elibc_glibc"
# only runtime goes multilib
@@ -68,6 +68,9 @@ multilib_src_configure() {
fi
use cxx || export CXX=$(tc-getCC)
+ # Should be able to drop this hack in next release. #333887
+ tc-is-cross-compiler && export gl_cv_func_working_acl_get_file=yes
+
local ECONF_SOURCE=${S}
if ! multilib_build_binaries ; then
# for non-native ABIs, we build runtime only