summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/libperl/libperl-5.8.1_rc1.ebuild')
-rw-r--r--sys-devel/libperl/libperl-5.8.1_rc1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-devel/libperl/libperl-5.8.1_rc1.ebuild b/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
index 312c1ce4e090..3e6b540cc6d1 100644
--- a/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.1_rc1.ebuild,v 1.1 2003/07/11 05:57:55 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.1_rc1.ebuild,v 1.2 2003/07/12 02:52:41 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -162,6 +162,13 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
+ if [ "`use mips`" ]
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf="${myconf} -Dd_u32align"
+ fi
if [ "`use sparc`" ]
then
myconf="${myconf} -Ud_longdbl"