summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 389a9d3024bc..0f1426b67ad5 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.133 2013/01/17 00:42:19 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.134 2013/01/17 18:06:51 ssuominen Exp $
EAPI=4
@@ -42,7 +42,6 @@ COMMON_DEPEND=">=sys-apps/util-linux-2.20
DEPEND="${COMMON_DEPEND}
dev-util/gperf
- >=dev-util/intltool-0.50
virtual/os-headers
virtual/pkgconfig
!<sys-kernel/linux-headers-${KV_min}
@@ -53,7 +52,8 @@ if [[ ${PV} = 9999* ]]
then
DEPEND="${DEPEND}
app-text/docbook-xsl-stylesheets
- dev-libs/libxslt"
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50"
fi
RDEPEND="${COMMON_DEPEND}
@@ -129,6 +129,16 @@ src_prepare()
EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
fi
+ # Remove requirements for dev-util/intltool, sys-devel/gettext, see #443028
+ if ! has_version dev-util/intltool && ! [[ ${PV} = 9999* ]]; then
+ sed -i \
+ -e '/INTLTOOL_APPLIED_VERSION=/s:=.*:=0.40.0:' \
+ -e '/XML::Parser perl module is required for intltool/s|^|:|' \
+ configure || die
+ eval export INTLTOOL_{EXTRACT,MERGE,UPDATE}=/bin/true
+ eval export {MSG{FMT,MERGE},XGETTEXT}=/bin/true
+ fi
+
# apply user patches
epatch_user